[Bioperl-l] WUBlastSearchEngine

nisa_dar vdar at yorku.ca
Thu May 22 19:00:57 EDT 2008


I have the older version of WUBlast and its path is the same which is being
mentioned in the error message below. I have changed this path in the
WuBlastSearchEngine.pm as well, 


  my $wuEngine = WUBlastSearchEngine->new( 
                   
pathToEngine=>"/home/vdar/RepeatMasker/blast2.linux-5.1/blastn" );

 although i didn't know if it was needed or no. These are a few more lines
which i haven't changed but I don't know if I need to change them

$wuEngine->setMatrix( "/users/bob/simple.matrix" );
  $wuEngine->setQuery( "/users/bob/query.fasta" );
  $wuEngine->setSubject( "/users/bob/subject.fasta" );
  my $searchResults = $wuEngine->search();

 
.. does anyone know what should I change in order to get results instead of
an error?

Thanks



nisa_dar wrote:
> 
> Does anyone know what does that mean and how to fix it? I'm running
> repeatmasker from commandline and WUBlastSearchEngine.pm is inside this
> directory. I installed WU blast. I can't understand how to fix this error
> now?
> 
> [vdar at capsella RepeatMasker]$ ./RepeatMasker boechera.fasta 
> RepeatMasker version open-3.2.3
> Search engine: WUBlast
> WUBlastSearchEngine::setPathToEngine( /state/partition1/bin/blast2/blastp
> ): Cannot determine engine variant and version!
>  at ./RepeatMasker line 534
> 
> I have seen line 534 on this program but I couldn't understand what I need
> to do?
> 
> Can you help?
> 
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/WUBlastSearchEngine-tp17414548p17415278.html
Sent from the Perl - Bioperl-L mailing list archive at Nabble.com.



More information about the Bioperl-l mailing list